Installation Overview and Troubleshooting Guide

Installation Overview and Troubleshooting Guide

Hardware Installation Overview

  1. Identify components included in the kit.
    (1) Communication gateway 
    (2) Cellular antennae
    (1) GPS antenna
    (1) Wifi antenna (not required for typical installation)
    (1) Easy connect harness
    (1) Ethernet network cable
    (1) 120VAC power supply (not required for typical installation)
    (1) RS232 comm port breakout board and cover
    (1) Din rail 
  2. Identify existing din rail for mounting of gateway or find suitable location to mount included piece. Gateway should be mounted in interior of gen controller enclosure where possible to limit vibration and weather exposure.
  3. Connect included cell antennae to AUX and ANT ports on top of the gateway. Mount as close to outside of gen enclosure as possible. Antennae ends should be separated approximately 12”-18”. Installation of a drip loop is required to keep water from entering unit.
  4. Connect included GPS antenna to GPS port on top of gateway. Mount as close to outside of gen enclosure as possible. Installation of a drip loop is required to keep water from entering unit.
  5. Inspect wiring harness and identify customer and gateway ends. Gateway end will have 3 pre-wired green terminal blocks.
  6. Route customer end to be near generator termination points. See generator controller specific reference pages for recommended terminations.
  7. Make final connections on customer end per documentation.
  8. Connect 7 pin terminal block (TB1) with Red, Black, Orange/White, White/Orange, and Blue/White wires to terminal block receptacle on top of communication gateway. 

  9. Confirm data cable connections are correct on gateway side for either RS485 (A/B) or RS232 (TXD/RXD) applications. 
  10. Connect 8 pin terminal block (TB2) with Yellow, White, Green, Purple, and Orange wires to front side, top terminal block receptacle. 
  11. Connect 8 pin terminal block (TB3) with Brown, Black, and Blue wires to front side, bottom terminal block receptacle. 

  12. If included ethernet cable is being used for communications, connect to the bottom port on front of gateway labeled ‘GE0/2’. 
    Gateway default settings:
    IP Address: 192.168.2.1
    Subnet Mask: 255.255.255.0 
  13. External device will need to be programmed with like IP address for communication to be established. Suggested IP settings:
    IP Address: 192.168.2.2  
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.2.1 

Generic Termination Notes 

Generac Gateway Side Termination 

Description 

Wire Color 

Customer Side Terminations 

TB1 V+ 

DC+ 

Red 

*B+ 

TB1 V- 

DC- 

Black 

*B- 

TB1 TXD (RS232) 

Data Transmit 

Orange/White 

2-RXD 

TB1 RXD (RS232) 

Data Receive 

White/Orange 

3-TXD 

TB1 GND 

Data GND 

White/Blue 

GND 

TB1 A (RS485) 

Data +  

Orange/White 

Modbus + 

TB1 B (RS485) 

Data - 

White / Orange 

Modbus - 

TB2 DICOM 

Input Common 

Orange 

 **B- or B+ 

TB2 DI0 

Input 1 

Purple 

Engine Running 

TB2 DI1 

Input 2 

Green 

Not in Auto 

TB2 DI2 

Input 3 

White 

Common Alarm 

TB2 DI3 

Input 4 

Yellow 

Spare Input 

Harness Relay #1 

COM 

Blue 

2-Wire Gen Start 

N/O 

White / Blue 

N/C 

Blue / White 

Harness Relay #2 

COM 

Brown 

Spare Output 

N/O 

Green / Yellow 

N/C 

White / Orange 


*If gateway power lights blink on gen crank this can indicate a brief loss of power to gateway. To correct, please make power connections directly to battery posts. 
 
**Gateway can support either positive or negative inputs for ‘On’ condition. If Orange wire is terminated to DC- then gateway will sense an ‘On’ condition when input wires (Purple/Green/White/Yellow) have DC+ signal applied. If Orange wire is terminated to DC+ then gateway will sense an ‘On’ condition when input wires have DC- signal applied. 

Troubleshooting

Issue 1:  Site not Reporting Data (N/A and Xs shown) when Streaming Attempted

 


Root Cause
Gateway network connectivity issue. 


Troubleshooting Steps


  1. Confirm PWR light is solid on.
  2. If PWR light is off, check red and black wire connections and voltage.
  3. Check harness inline fuse; replace if blown.
  4. Confirm SIM1 light is On. If SIM1 light is Off, power down gateway and remove SIM card slot cover on top of gateway. Then confirm card is installed in SIM1 position in correct direction (note arrow on image showing direction for install). SIM should click into position when installed correctly. Reinsert SIM and power gateway back up.
  5. Confirm MODEM light is On. If MODEM light is Off, check signal light indicators. Confirm at least two signal lights are on. Confirm antennae are firmly connected. Move antenna to highest point possible.
  6. Note Verizon coverage in area via cell phone signal if possible. Identify if alternative carrier (AT&T / T-Mobile) may have better reception in area by speaking with local site contacts.
  7. Cycle power to gateway by removing and reinserting inline harness fuse. Wait approximately one minute and check MODEM and signal lights again.
  8. If not able to resolve issue, contact Generac install support at 1-888-234-3212 Option 4 or iothelp@bluepillar.com.
Issue 2:  Site Reporting -99 for Data Points

Root Cause
Gateway not able to establish Modbus communication to field device(s).

Troubleshooting Steps
  1. Check gateway side data cable connections on TB1 (OR/WH, WH/OR, BLU/WH).
  2. For RS232 applications (for example, G or H Panel)
    TXD—Orange / White
    RXD—White / Orange
    GND—Blue / White
  3. For RS485 applications (for example, DSE 7300 or Generac PZ Pro)
    A—Orange / White
    B—White / Orange
    GND—Blue / White
  4. Check customer / device side connections
  5. For RS232 applications use provided breakout board
    2 RXD (Receive)—Orange / White
    3 TXD (Transmit)—White / Orange
    5 GND (Ground)—Blue / White
  6. For RS485 applications
    Modbus POS—Orange / White
    Modbus NEG—White / Orange
    Modbus REF—Blue / White
  7. Confirm ethernet connected devices are programmed with the correct IP address.
    Suggested IP settings:
    IP Address: 192.168.2.2 
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.2.1
  8. If not able to resolve issue, contact Generac install support at 1-888-234-3212 Option 4 or iothelp@bluepillar.com

    • Related Articles

    • Gateway Connectivity Installation Wizard

      Gateway Connectivity Installation Wizard Using the steps included in this topic, IDC Technicians will be equipped to deploy an Advanced Gateway for a Site with a connected generator from a variety of manufacturers. These installations typically will ...
    • Generac H Panel

      Click here to view the Generac H Panel quick guide.
    • Generac Industrial Connectivity API Reference

      Please find attached the Generac Industrial Connectivity API Integration Reference document.
    • How to book and appointment with a dedicated Engineer

      Concern: Availability of a dedicated Engineer for an Industrial Advanced Gateway installation. This is a friendly reminder of the importance of booking a remote support appointment with one of our dedicated engineers. Installing gateways can ...
    • Enhanced MiraLink Help Center is Live!

      We are excited to share that our new customer support portal is live! You’ll notice both an expanded knowledge base and new ticket system, allowing you to follow or submit troubleshooting tickets in real time. Be sure to check the portal for system ...